概述

goorm 中创建新容器时,会发现 Go 语言的版本为 1.10.2。这样就会带来一个问题:无法在此版本的 go 环境上使用 go mod 管理依赖。

更改方法

由于 goorm 提供的是管理员账户,所以可以自行替换 go 版本。

cd /

wget https://golang.org/dl/go1.16.3.linux-amd64.tar.gz

rm -rf /usr/local/go/

tar -C /usr/local -xzf go1.16.3.linux-amd64.tar.gz

export PATH=$PATH:/usr/local/go/bin

验证

go version ==> go version go1.16.3 linux/amd64

常见错误

  • 会不定时的环境报错,直接按上面的步骤重新安装即可,容器内的文件会一直保存的。